What model is this?

nmiller

Member
Joined
Jul 21, 2008
Messages
180
Reaction score
10
It was sold to me as a Model 66 with a replaced speaker. The speaker turned out to be an RCA dated 4 weeks before the pots in 1956, so I think it's original (maybe a recone? I don't know). The tubes appear to all be the original RCAs as well. Someone has opened it up before (two screws are missing) but I see no evidence of a cap job or other work.

My understanding is that the 66 and anything else with a Masteramp tag ran on 50L6s without a power transformer, but this is a dual-6V6 amp with transformers ahoy. It basically looks like a 66-J with the cabinet and speaker of an earlier amp. I was able to find pics of only one other Guild amp with the air vents on top. Is this a known variation? The label is gone, so should I call this a 66 or 66-J?






 

Default

Super Moderator
Joined
Jul 30, 2007
Messages
10,756
Reaction score
72
I'll have to look at it on the computer, but there were some bizarre amps coming out of Guild around 56. The RCA speaker is woefully underpowered for two 50L6s @8 watts, and should be downright suicidal at the thought of handling a couple of 6v6gts. My 66 and Vermonter's 66 were built months apart and have wildly different circuits, especially when it comes to the filtering and B+ circuits. This could be something cobbled together at the factory to use up parts or to fill an order.
 
Last edited:

Default

Super Moderator
Joined
Jul 30, 2007
Messages
10,756
Reaction score
72
I have a couple of amps that appear to have that chassis. Those amps have two 6L6s mounted on the chassis and the rectifier and can cap are bolted to the bottom of the cabinet. The power supply is connected to the chassis with an umbilical cord. The speaker in each of those is a Jensen P12P. I would suspect that this is a case of Guild using up surplus parts...
 

Default

Super Moderator
Joined
Jul 30, 2007
Messages
10,756
Reaction score
72
That one tube looks like it was made the last week of 57. Guild used a lot of surplus in the mid fifties amps. I have a 40-T that was sold in the early Sixties, but had a cancap from 1955.
 

nmiller

Member
Joined
Jul 21, 2008
Messages
180
Reaction score
10
Interesting! I half expected someone to say "it's a standard '56, you just didn't look at the right catalog".

It sounds similar to the later 66-Js I've owned, but a tad boxier; I don't know if that's down to the speaker, the circuit, the cab, or what. I was going to say that it has slightly less headroom than later examples, but maybe that's the speaker maxing out early. If it's really rated for 8W, I better swap it out to preserve it; I'll bet someone blew it before, and they confused a recone with a replacement. The trem is dead, but I never use it anyway.
 

Default

Super Moderator
Joined
Jul 30, 2007
Messages
10,756
Reaction score
72
No, I think that is the stock speaker. I suspect that, in Guildian fashion, they used up stock, rather than paying for new. The RCAs didn't appear in any other model. Looking at the chassis (mid 50s) cab (mid 50s) and the tube lineup(roughly 57 and later, with the 6SN7 replaced with a 12A*7) I would guesstimate that it was constructed late 1956 to 1958, when the cabinet changed to the trapizoid speaker grill, the tweed/brown cloth and the Ampeg chassis.
 

Default

Super Moderator
Joined
Jul 30, 2007
Messages
10,756
Reaction score
72
I would concur that it is crippled by that speaker. It's a hifi speaker, not a guitar speaker. I would be interested in that amp, down the line.
 
Last edited:
Top