Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Most popular/common Guild amp from late 60s to early 70s.

  1. #11
    I just got a Maverick guitar amp (not bass from what I can tell). I LOVE it. @mavuser you're right. That tremolo sold me. I had no intention of buying another amp and then I couldn't get that tremolo out of my mind. (I ended up selling a much beloved Alamo Montclair because I love the Maverick more. It was one of those rare pieces that just spoke to me. Also the Alamo's going to a friend who lost his in a flood. The Mav just made it a little easier to part with it.) I just got it, so I have a couple of questions and was wondering if someone could help me out.

    #1) Does anyone have the schematic for the 1971 Maverick guitar amp?

    #2) There's no foot switch, right? I can't find a 1/4 inch input/jack for one. Am I missing something? Is there a way to add one so I can turn the trem/rev off while playing?

    #3) And this is probably a general amp question, but I can't figure out the "skittles-ish" noise that I get from it every now and again. Sometimes it works beautifully, and other times, when I play, it gets this weird staticky, noise like if you play a tube amp just as the power is going off. Is that a bad tube? If so, how do I safely identify it?

    Any advice would be much appreciated. (Just don't ask me if it's the guitar or cables. It's not.)

    Thanks, Guild lovers.
    Last edited by DDickens; 10-03-2017 at 05:49 AM.

  2. #12
    Super Moderator Default's Avatar
    Join Date
    Jul 2007
    Location
    Philly, or thereabouts
    Posts
    9,373
    Hi! Glad you found a Maverick, l have one as well. The schematic is at Prowess amplifiers under miscilanious. The footswitch uses rca jacks on the back panel. The occasional glitchy noise might be dirty tube pins or sockets. Try pulling the tubes part way out and then in 5-6 times to clean them off.

    Hope that helps!
    "Steve, you are a man of many goats."~ capnjuan

    "Alternatively, you could just go the ultra-relic route with it. Basically go for a look that says the amp was on fire and they put it out using belt sanders."
    (amps - I need a "99" & "50")

  3. #13
    nice, glad there is yet another mav user out there!

    I find with my amps they dont seem to like the footswitch. although it is a very convenient feature to have, I just use the knobs to turn the effects off (and on).

    enjoy the mav!!

  4. #14
    Quote Originally Posted by AcornHouse View Post
    No Master volume on the Thunderstar; just two different volumes for the two channels, ala a Bassman.
    Interestingly, I found a super useful quirk of the thinderstar design while working on mine. If you leave the tremolo tube out, the intensity knob will reduce the output volume as you turn it up. Because of where the term is in the circuit you can still crank the volume to get overdrive, then dial back the output volume with the intensity knob, much like a master volume. I'm not sure why this works, I hope it's not damaging anything. If anyone can explain it, I'd love to know what's going on electrically.

  5. #15

    Maverick "Lead"

    Thanks! I actually had to buy a schematic for the Maverick "Lead," but it was worth it. I ended up replacing the tubes, which sounds just fine; however it turns out I'm going to have to replace a speaker. These are 10" 50W 4 ohm, right? I can't figure out the coding on the speaker. Any advice? I know the CTS code, but I don't understand the rest of it. Anyone care to drop some knowledge?

    137
    018013
    708

    I'll try to get a photo up.

    Doug

  6. #16
    Super Moderator Default's Avatar
    Join Date
    Jul 2007
    Location
    Philly, or thereabouts
    Posts
    9,373
    They are box stock 8 ohm CTS 10 inch speakers, same a Fender used in some of their amps. Replacethem with a decent set of Webers, or whatever floats your boat, sonically speaking. Make sure that the speakers are 8 ohms impedance and wired in parallel for a 4 ohm total load and you will be golden.
    "Steve, you are a man of many goats."~ capnjuan

    "Alternatively, you could just go the ultra-relic route with it. Basically go for a look that says the amp was on fire and they put it out using belt sanders."
    (amps - I need a "99" & "50")

  7. #17
    Quote Originally Posted by Default View Post
    They are box stock 8 ohm CTS 10 inch speakers, same a Fender used in some of their amps. Replacethem with a decent set of Webers, or whatever floats your boat, sonically speaking. Make sure that the speakers are 8 ohms impedance and wired in parallel for a 4 ohm total load and you will be golden.
    Thanks, Steve. I really appreciate the reply.
    Doug

  8. #18
    I put the jensen C10Q 8 Ohm reissues in mine. they are 35 watts each, instead of 25. So a little louder maybe, or more headroom or power for pedals, or something. But they sound just like the old CTS that were in there. I found Weber sound clips and other speakers to sound fantastic, but the Jensens sound the most like the mav. heres a link to the speaker-

    http://www.musiciansfriend.com/acces...F-adType%5EPLA

    in retrospect now that ive replaced everything else in the amp, I wonder how the old speakers sound. They were never blown or anything, just tired sounding. but the new ones sound nice

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •